iOS 4.3.5 Software Update released by Apple to fix ANOTHER security vulnerability with certificate validation.

Products compatible with this software update:
• iPhone 4 (GSM model)
• iPhone 3GS
• iPad 2
• iPad
• iPod touch (4th generation)
• iPod touch (3rd generation)

For information on the security content of this update, please visit this website:
<http://support.apple.com/kb/HT1222>